Penelope – AU Client Performance Degradation and Timeout Errors

Monitoring

We implemented a fix to address the performance issues and we are actively monitoring to ensure there is no regression. Please continue to monitor this page for additional updates.
Posted Mar 10, 2026 - 15:00 EDT

Identified

We have identified the root cause that is impacting performance. We are actively working on an update to remediate further, so please continue to monitor this page for additional updates.
Posted Mar 10, 2026 - 13:34 EDT

Update

We are continuing to investigate this issue and resolve this issue as a top priority. We apologize for any inconvenience and appreciate your patience as we continue to address the issue.
Posted Mar 10, 2026 - 10:35 EDT

Investigating

We are currently investigating reports of performance degradation impacting a subset of AU clients. Affected users may experience latency during navigation and page loads, and in some cases, receive timeout or proxy-related errors. Our team is actively working to identify the root cause and restore normal performance.
Posted Mar 10, 2026 - 09:35 EDT
This incident affects: Penelope.