As of 5:35pm ET system performance has returned to normal, and the issue has been resolved. We’ll continue to monitor to ensure ongoing stability.
Posted Jul 28, 2025 - 17:40 EDT
Monitoring
The issue has been identified and a temporary mitigation is in place. Users should not be experiencing any issues at this time. A permanent resolution is in progress.
Posted Jul 28, 2025 - 10:09 EDT
Investigating
We're currently investigating an issue that may be preventing a subset of users on app.ngpvan.com from running Create a List searches or loading Targeted Email audiences.