Intermittent Connectivity issues due to a Widespread Cloudflare Incident affecting clients Globally

Resolved

Cloudflare has implemented a fix for the upstream issue that caused intermittent errors earlier today.

All Bonterra and NGP VAN services are now fully operational. We’ll continue to monitor performance closely to ensure ongoing reliability.

Thank you for your patience during this disruption.
Posted Nov 18, 2025 - 14:25 EST

Update

We continue to see positive recovery across our portfolio but there are still some instances of queues for re-synchronization not yet having completed. Naturally we're working to resolve this as we complete the clean up after this global Cloudflare incident.
Posted Nov 18, 2025 - 11:52 EST

Monitoring

According to the Cloudflare website, https://www.cloudflarestatus.com, a fix has been implemented and we are seeing the Bonterra Tech applications coming back on line accordingly. However, there may be some continued functional degradation as various components re-sync and regain their pre-issue status.

We will continue to update this page with appropriate information to keep you appraised of progress towards the full return to normal service.
Posted Nov 18, 2025 - 10:12 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 08:37 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 08:36 EST

Update

We continue to rely on Cloudflare to resolve this issue - updates from them directly are available here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 08:19 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 08:00 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 07:13 EST

Investigating

We are aware of intermittent connectivity issues affecting NGPVAN, VoteBuilder, GiveGab Enterprise, GiveGab Core, EveryAction and WeSpire - This appears to be caused by a widespread problem with Cloudflare and specifically ,the CDN. We are working with their support personnel to assist in rectification.
Posted Nov 18, 2025 - 07:09 EST
This incident affected: Apricot, ETO, EveryAction, NGP VAN, CyberGrants, Network for Good, GiveGab, GiveGab Enterprise, DonorTrends, Mobilize, WeSpire, and Nonprofit Hub.