CyberGrants: Reported Performance Issues

Postmortem

Issue Summary:

On May 4th, 2026, when an email campaign was sent with call to action the event search pages were slow to respond and timed out in some cases.

Root Cause:

An edge case in the event configuration was identified that caused the SQL execution plan to be very costly. The increased load on the system in conjunction with the slow query plan caused slowness/timeouts.

Prevention:

Short term, we vertically scaled the database, and also altered the event configuration slightly to help optimize the query. As for a permanent solution we are working to ensure that this edge case is covered correctly by the query optimizer. That may involve altering the query used by the application and/or adding covering indexes to ensure the query optimizer picks the best plan.

Posted May 07, 2026 - 10:12 EDT

Resolved

This incident has been resolved.
Posted May 04, 2026 - 14:45 EDT

Monitoring

We have completed an update to address the delay/latency issue. We will continue to monitor to ensure there are no further issues. Please continue to monitor this page for further updates.
Posted May 04, 2026 - 12:22 EDT

Investigating

We are currently reviewing an issue that is causing delays/latency issues with CyberGrants. This is a top priority and we are actively working to remediate as soon as possible. Please monitor this page for further updates.
Posted May 04, 2026 - 11:05 EDT
This incident affected: CyberGrants.