CyberGrants Monitoring Latency Issues

Resolved

We’ve successfully resolved the sporadic latency issue affecting portions of the platform. All systems are operating normally, and our monitoring shows stable performance.
Posted Nov 13, 2025 - 17:36 EST

Monitoring

The latency issue has been addressed, but we are actively monitoring performance to ensure there is no regression. Please continue to monitor this page for further updates.
Posted Nov 13, 2025 - 16:48 EST

Investigating

We are currently observing some sporadic latency affecting portions of the platform. Our teams are actively monitoring performance and investigating the underlying cause.
Posted Nov 13, 2025 - 15:52 EST
This incident affected: CyberGrants.