Salsa: Delay in Sending Scheduled Emails

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 17:20 EDT

Monitoring

The processing of the current queue of scheduled emails is now underway, so any delayed emails should be sent shortly. We will continue to monitor closely, Please continue to view this page for further updates,
Posted Jul 29, 2025 - 14:33 EDT

Investigating

We are currently investigating an issue that is causing a delay in the delivery of scheduled emails. Our technical team is actively investigating the root cause and working to resolve the issue as quickly as possible. We understand the impact this may have on your operations and appreciate your patience as we work toward a resolution.
Posted Jul 29, 2025 - 14:18 EDT
This incident affected: Salsa.